use strict;
my $str = 'Nunc scelerisque risus lectus, id ultricies nulla vulputate eu.
Quisque fermentum pretium pharetra. Etiam nec felis diam.
Curabitur pretium suscipit ex sed pulvinar.
In interdum eget massa sed posuere.
Aliquam rutrum auctor tempor.
Praesent sodales eu massa rhoncus efficitur.
Proin egestas non erat vitae feugiat. Suspendisse rutrum placerat fermentum.
Nulla tincidunt leo ut lectus semper pellentesque.
Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Ut scelerisque velit ac porta tristique.
';
my $regex = qr/^$\n(^$\n)*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";