import re
regex = re.compile(r"\n(\n+)", flags=re.MULTILINE)
test_str = ("A\n"
"B\n\n\n"
"C\n\n\n\n\n"
"D")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)