using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\[]\S+)\[([^\[\s]*)\]([^\[\]]*)\[(s*)?";
string input = @"Status[STRING] Reason[STRING]";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}