package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)([^\[]\S+)\[([^\[\s]*)\]([^\[\]]*)\[(s*)?`)
var str = `Status[STRING] Reason[STRING]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}