re = /([^\[]\S+)\[([^\[\s]*)\]([^\[\]]*)\[(s*)?/i
str = 'Status[STRING] Reason[STRING]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end