use strict;
my $str = '1
12
123
123.456.789.884
12.55
12.345
2,234,647
2,234_754
2 234 723
123456
1
12
123
1234
12345
123456
1234567
123.456789
12.123.
1234567890,';
my $regex = qr/^(?:\d+|\d{1,3}([ _.,])\d{3}(?:\1\d{3})*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}