import re
regex = re.compile(r"^(?:\d+|\d{1,3}([ _.,])\d{3}(?:\1\d{3})*)$", flags=re.MULTILINE)
test_str = ("1\n"
"12\n"
"123\n"
"123.456.789.884\n"
"12.55\n"
"12.345\n"
"2,234,647\n"
"2,234_754\n"
"2 234 723\n"
"123456\n"
"1\n"
"12\n"
"123\n"
"1234\n"
"12345\n"
"123456\n"
"1234567\n"
"123.456789\n"
"12.123.\n"
"1234567890,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")