using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)# Extended (whitespace and comments are ignored)
([^[]+) # Group 1: 1 or more non-'[' characters
(?: # Start of a non-capturing group 1
\s* # Match optional whitespace
\[ # Match '['
([^&\]]+) # Group 2: 1 or more non- '&' or ']' characters
(?: # Start of a non-capturing group 2
\s* # Match optional whitespace
& # Match '&'
\s* # Match optional whitespace
([^\]]+) # Capture group 3: 1 or more non-']' characters
\s* # Match optional whitespace
)* # End of optional non-capturing group 2
] # Match ']'
)* ";
string input = @"text [text1 & text2]
text [text1]
text [text2]
text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}