import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)# Extended (whitespace and comments are ignored)\n"
+ "([^[]+) # Group 1: 1 or more non-'[' characters\n"
+ "(?: # Start of a non-capturing group 1\n"
+ " \\s* # Match optional whitespace\n"
+ " \\[ # Match '['\n"
+ " ([^&\\]]+) # Group 2: 1 or more non- '&' or ']' characters\n"
+ " (?: # Start of a non-capturing group 2\n"
+ " \\s* # Match optional whitespace\n"
+ " & # Match '&'\n"
+ " \\s* # Match optional whitespace\n"
+ " ([^\\]]+) # Capture group 3: 1 or more non-']' characters\n"
+ " \\s* # Match optional whitespace\n"
+ " )* # End of optional non-capturing group 2\n"
+ " ] # Match ']'\n"
+ ")* ";
final String string = "text [text1 & text2]\n"
+ "text [text1]\n"
+ "text [text2]\n"
+ "text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}