const regex = new RegExp('(?x)# Extended (whitespace and comments are ignored)
([^[]+) # Group 1: 1 or more non-\\'[\\' characters
(?: # Start of a non-capturing group 1
\\s* # Match optional whitespace
\\[ # Match \\'[\\'
([^&\\]]+) # Group 2: 1 or more non- \\'&\\' or \\']\\' characters
(?: # Start of a non-capturing group 2
\\s* # Match optional whitespace
& # Match \\'&\\'
\\s* # Match optional whitespace
([^\\]]+) # Capture group 3: 1 or more non-\\']\\' characters
\\s* # Match optional whitespace
)* # End of optional non-capturing group 2
] # Match \\']\\'
)* ', 'gm')
const str = `text [text1 & text2]
text [text1]
text [text2]
text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}