re = /Tap on a clip to paste it in the text box./m
str = 'Tap on a clip to paste it in the text box.Use the edit icon to pin, add or delete clips.Welcome to Gboard clipboard, any text you copy will be saved here.
basserotwo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end