#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\.)(\b(?:\d{2,3}|[2-9])(?:\.\d+)?\b|\b1\.(?:1\d?|0[1-9])\b)(?!%|\.)"
Local $sString = "0.32 100.00 5.6 0.27 98% 12.2% 1.01 0.99% 0.99 13.13 1.10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")