import Foundation
let pattern = #"(?<!\.)(\b(?:\d{2,3}|[2-9])(?:\.\d+)?\b|\b1\.(?:1\d?|0[1-9])\b)(?!%|\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"0.32 100.00 5.6 0.27 98% 12.2% 1.01 0.99% 0.99 13.13 1.10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)