using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(?![A-Z])([^ ]+)|([A-Z][a-z]+))";
string input = @"Jones Smith 9sfjn Hobbes 23r4tgr9h CSV Csv vVv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}