re = /(?(?![A-Z])([^ ]+)|([A-Z][a-z]+))/m
str = 'Jones Smith 9sfjn Hobbes 23r4tgr9h CSV Csv vVv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end