$re = '/(?(?![A-Z])([^ ]+)|([A-Z][a-z]+))/m';
$str = 'Jones Smith 9sfjn Hobbes 23r4tgr9h CSV Csv vVv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);