package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([Hh][Ee][Yy](?R)?oh)`)
var str = `heyoh heyyoh hEyHeYohoh hey oh heyhey hEyHeYHEyohohoh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}