$re = '/([Hh][Ee][Yy](?R)?oh)/m';
$str = 'heyoh heyyoh hEyHeYohoh hey oh heyhey hEyHeYHEyohohoh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);