using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*\.\d+[fF]?|\d+\.\d*[fF]?|\d+[lLfF]?";
string input = @"42L 12 x 3.4f 6l 3.3 0F L F .2F 0.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}