re = /\d*\.\d+[fF]?|\d+\.\d*[fF]?|\d+[lLfF]?/m
str = '42L 12 x 3.4f 6l 3.3 0F L F .2F 0.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end