$re = '/\d*\.\d+[fF]?|\d+\.\d*[fF]?|\d+[lLfF]?/m';
$str = '42L 12 x 3.4f 6l 3.3 0F L F .2F 0.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);