using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z][a-z][a-z][a-z]+)|([A-Z][a-z]?[a-z]?)";
string input = @"Kim Jobs Xu Cloyd Mohr Ngo Rock";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}