$re = '/([A-Z][a-z][a-z][a-z]+)|([A-Z][a-z]?[a-z]?)/m';
$str = 'Kim Jobs Xu Cloyd Mohr Ngo Rock';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);