package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z][a-z][a-z][a-z]+)|([A-Z][a-z]?[a-z]?)`)
var str = `Kim Jobs Xu Cloyd Mohr Ngo Rock`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}