package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^aeiou ]\w*)|(\w+)`)
var str = `pds6f uub 24r2gp ewqrty l ui_op`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}