const regex = /([^aeiou ]\w*)|(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^aeiou ]\\w*)|(\\w+)', 'gm')
const str = `pds6f uub 24r2gp ewqrty l ui_op`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}