using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""\b[^""]{0,5}\b\""|\""\b[^""]+\s[^""]*\b\""";
string input = @"""12345"" ""my password"" ""Xanadu.2112"" ""su_do"" ""OfSalesmen!""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}