const regex = /\"\b[^"]{0,5}\b\"|\"\b[^"]+\s[^"]*\b\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"\\b[^"]{0,5}\\b\\"|\\"\\b[^"]+\\s[^"]*\\b\\"', 'gm')
const str = `"12345" "my password" "Xanadu.2112" "su_do" "OfSalesmen!"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}