import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"\\b[^\"]{0,5}\\b\\\"|\\\"\\b[^\"]+\\s[^\"]*\\b\\\"";
final String string = "\"12345\" \"my password\" \"Xanadu.2112\" \"su_do\" \"OfSalesmen!\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}