import re
regex = re.compile(r"\/(?!.*\.)[^\/]+$", flags=re.MULTILINE)
test_str = ("www.mysite.com/page\n"
"www.mysite.com/page/\n"
"www.mysite.com/file.php\n"
"www.mysite.com/file.jpg\n"
"www.mysite.com/file.html\n"
"www.mysite.com/file.doc")
subst = "$0\\/"
result = regex.sub(subst, test_str)
if result:
print(result)