re = /\/(?!.*\.)[^\/]+$/m
str = 'www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc'
subst = '$0\\/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result