#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\".*?\")|(\S+/\S+)"
Local $sString = "some text/more text "dont match/me" divideme/(byme)" & @CRLF & _
"(formula)/dividethis" & @CRLF & _
"divideme/(byme) "dont match/me hel d/b lo a/b" divideme/(byme)" & @CRLF & _
""dont match/me""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")