// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:\".*?\")|(\S+/\S+)"#).unwrap();
let string = "some text/more text \"dont match/me\" divideme/(byme)
(formula)/dividethis
divideme/(byme) \"dont match/me hel d/b lo a/b\" divideme/(byme)
\"dont match/me\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}