re = /(?:\".*?\")|(\S+\/\S+)/m
str = 'some text/more text "dont match/me" divideme/(byme)
(formula)/dividethis
divideme/(byme) "dont match/me hel d/b lo a/b" divideme/(byme)
"dont match/me"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end