package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|(.+?)\|`)
var str = `PROTEIN\t1\t0\ttr|Q6ZN40|Q6ZN40_HUMAN\t\t-1\t;;;;;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}