re = /\|(.+?)\|/m
str = 'PROTEIN\\t1\\t0\\ttr|Q6ZN40|Q6ZN40_HUMAN\\t\\t-1\\t;;;;;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end