#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\??[^a-zA-Z0-9ğ ] ?\w*(?<![dD]e.il) (mi\s?\?)"
Local $sString = "---MATCH---" & @CRLF & _
"Ahmet mi?" & @CRLF & _
"Ahmet mi ?" & @CRLF & _
"Beğendiniz mi?" & @CRLF & _
"Değil mi? Michael mi?..." & @CRLF & _
"Hadi bakalım. Ahmet mi?" & @CRLF & _
"Hadi bakalım, Ahmet mi?" & @CRLF & _
"Hadi bakalım. Ahmet mi ?" & @CRLF & _
"Hadi bakalım. Olabilir mi?" & @CRLF & _
"Michael mi? Neden bana söylemediniz?" & @CRLF & _
"" & @CRLF & _
"---NON-MATCH---" & @CRLF & _
"Hadi bakalım. Gelecek olan Ahmet mi?" & @CRLF & _
"Bunu beğendiniz mi?" & @CRLF & _
"Değil mi?" & @CRLF & _
"Olabilir değil mi?" & @CRLF & _
"Değil mi ?" & @CRLF & _
"Ahmet.mi?" & @CRLF & _
"mi?" & @CRLF & _
"Mi?" & @CRLF & _
"Minik?" & @CRLF & _
"Kimi?"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)