using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\??[^a-zA-Z0-9ğ ] ?\w*(?<![dD]e.il) (mi\s?\?)";
string substitution = @"";
string input = @"---MATCH---
Ahmet mi?
Ahmet mi ?
Beğendiniz mi?
Değil mi? Michael mi?...
Hadi bakalım. Ahmet mi?
Hadi bakalım, Ahmet mi?
Hadi bakalım. Ahmet mi ?
Hadi bakalım. Olabilir mi?
Michael mi? Neden bana söylemediniz?
---NON-MATCH---
Hadi bakalım. Gelecek olan Ahmet mi?
Bunu beğendiniz mi?
Değil mi?
Olabilir değil mi?
Değil mi ?
Ahmet.mi?
mi?
Mi?
Minik?
Kimi?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}