# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\??[^a-zA-Z0-9ğ ] ?\w*(?<![dD]e.il) (mi\s?\?)"
test_str = ("---MATCH---\n"
"Ahmet mi?\n"
"Ahmet mi ?\n"
"Beğendiniz mi?\n"
"Değil mi? Michael mi?...\n"
"Hadi bakalım. Ahmet mi?\n"
"Hadi bakalım, Ahmet mi?\n"
"Hadi bakalım. Ahmet mi ?\n"
"Hadi bakalım. Olabilir mi?\n"
"Michael mi? Neden bana söylemediniz?\n\n"
"---NON-MATCH---\n"
"Hadi bakalım. Gelecek olan Ahmet mi?\n"
"Bunu beğendiniz mi?\n"
"Değil mi?\n"
"Olabilir değil mi?\n"
"Değil mi ?\n"
"Ahmet.mi?\n"
"mi?\n"
"Mi?\n"
"Minik?\n"
"Kimi?")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.