use strict;
my $str = '<!DOCTYPE HTML><html lang="en"><head><meta charset="utf-8"><title>AlifPay</title><base href="/web/"><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="stk" content="1lPxBhJKqRKUG6q73mQt4wQoD5I"><link rel="icon" type="image/x-icon" href="./favicon.png"><link href="styles.99f15c62ba66cd524e55.bundle.css" rel="stylesheet"/></head><body><app-root></app-root><script type="text/javascript" src="inline.aced06935de18d27acc6.bundle.js"></script><script type="text/javascript" src="polyfills.34df2d66b4f714bfa1ad.bundle.js"></script><script type="text/javascript" src="main.0cea576e7bb8eeaea0e1.bundle.js"></script></body></html>
';
my $regex = qr/content="/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}