import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.mdm\\.[a-z0-9_.]{0,100})_";
final String string = " ips.mdm.table1_a \n"
+ " ips.mdm.table2_a_b \n"
+ " ips.mdm.table3_a\n"
+ " ips.mdm.table4_a_b_c\n"
+ " ips.mdm.table5.a_b\n"
+ " ips.mdm.table6_a_b_c";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}