$re = '/(?<=\.mdm\.[a-z0-9_.]{0,100})_/m';
$str = ' ips.mdm.table1_a
ips.mdm.table2_a_b
ips.mdm.table3_a
ips.mdm.table4_a_b_c
ips.mdm.table5.a_b
ips.mdm.table6_a_b_c';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;