const regex = new RegExp('(?<=\\.mdm\\.[a-z0-9_.]{0,100})_', 'gm')
const str = ` ips.mdm.table1_a
ips.mdm.table2_a_b
ips.mdm.table3_a
ips.mdm.table4_a_b_c
ips.mdm.table5.a_b
ips.mdm.table6_a_b_c`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);