import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*<VirtualHost.*?>.*?\\R\\h*<\\/VirtualHost>";
final String string = " <VirtualHost *:80>\n"
+ " ServerName localhost\n"
+ " DocumentRoot c:/wamp/www\n"
+ " <Directory \"c:/wamp/www/\">\n"
+ " Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
+ " AllowOverride All\n"
+ " Require local\n"
+ " </Directory>\n"
+ " </VirtualHost>\n"
+ " <VirtualHost *:8080>\n"
+ " ServerName testing.com\n"
+ " DocumentRoot c:/wamp/www/testing.com\n"
+ " <Directory \"c:/wamp/www/testing.com\">\n"
+ " Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
+ " AllowOverride All\n"
+ " Require local\n"
+ " </Directory>\n"
+ " </VirtualHost>\n"
+ " <VirtualHost 127.0.0.1:80>\n"
+ " ServerName testing2.com\n"
+ " DocumentRoot c:/wamp/www/testing2.com\n"
+ " <Directory \"c:/wamp/www/testing2.com\">\n"
+ " Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
+ " AllowOverride All\n"
+ " Require local\n"
+ " </Directory>\n"
+ " </VirtualHost>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}