import re
regex = re.compile(r"^\h*<VirtualHost.*?>.*?\R\h*<\/VirtualHost>", flags=re.DOTALL | re.MULTILINE)
test_str = (" <VirtualHost *:80>\n"
" ServerName localhost\n"
" DocumentRoot c:/wamp/www\n"
" <Directory \"c:/wamp/www/\">\n"
" Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
" AllowOverride All\n"
" Require local\n"
" </Directory>\n"
" </VirtualHost>\n"
" <VirtualHost *:8080>\n"
" ServerName testing.com\n"
" DocumentRoot c:/wamp/www/testing.com\n"
" <Directory \"c:/wamp/www/testing.com\">\n"
" Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
" AllowOverride All\n"
" Require local\n"
" </Directory>\n"
" </VirtualHost>\n"
" <VirtualHost 127.0.0.1:80>\n"
" ServerName testing2.com\n"
" DocumentRoot c:/wamp/www/testing2.com\n"
" <Directory \"c:/wamp/www/testing2.com\">\n"
" Options +Indexes +Includes +FollowSymLinks +MultiViews\n"
" AllowOverride All\n"
" Require local\n"
" </Directory>\n"
" </VirtualHost>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")