import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<numero>[1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\\-[0-9]{4})( (?&numero))*$";
final String string = "11 91129-1231\n"
+ "11 91231-2343 11 2322-4332\n"
+ "15 98221-9540 12 93853-2343 45 4332-0593";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}