$re = '/^(?<numero>[1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4})( (?&numero))*$/m';
$str = '11 91129-1231
11 91231-2343 11 2322-4332
15 98221-9540 12 93853-2343 45 4332-0593';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);