// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<numero>[1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4})( (?&numero))*$").unwrap();
let string = "11 91129-1231
11 91231-2343 11 2322-4332
15 98221-9540 12 93853-2343 45 4332-0593";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}