#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+CPAuth \(.*\:\d+\) response message\: The authentication has failed\, please login again\.$"
Local $sString = "| 24.03.22 14:11:08.351 MAIN ( PROCESS ) : CPAuth (185.214.223.14:44560) response message: The authentication has failed, please login again." & @CRLF & _
"`-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")