$re = '/^.+CPAuth \(.*\:\d+\) response message\: The authentication has failed\, please login again\.$/m';
$str = '| 24.03.22 14:11:08.351 MAIN ( PROCESS ) : CPAuth (185.214.223.14:44560) response message: The authentication has failed, please login again.
`-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);